Site_Feedback

Topic   Weird issue in Safari

SirConnery
GameTZ Subscriber 1000 Trade Quintuple Gold Good Trader Secret Santa
13-Mar-2016(#1)
Not a huge issue, but when I try to log in to GameTZ on my iPhone (Safari) I see the standard login screen. I enter my username and password. I click submit and then I get a blank page. Same thing happens on both mobile site and regular site. I've cleared my cookies, history, and cache multiple times and it happens each time. Started about 3 days ago.

I can install alternate browsers (Chrome, Firefox) and it works fine. This is only in Safari. If I don't login, I can browse the site as normal, but as soon as I try to login it gives the blank screen until I dump the cookies/cache again.

I'm going to try this on an iPad and see if there's a similar issue. Currently I have mobile Firefox installed so I can access and login on my phone. I use Safari for everything else, since it's the default browser on the iPhone.
SirConnery
GameTZ Subscriber 1000 Trade Quintuple Gold Good Trader Secret Santa
14-Mar-2016(#2)
Works fine on my iPad Air 2.
SirConnery
GameTZ Subscriber 1000 Trade Quintuple Gold Good Trader Secret Santa
14-Mar-2016(#3)
I have a temporary fix, I can use Safari to browse the mobile site if I disable JavaScript. It just looks strange, but it's fully functional. If I re enable JavaScript then it stops at a blank page again.
bill
GameTZ Gold Subscriber GameTZ Full Moderator 600 Trade Quintuple Gold Good Trader Gold Global Trader (15) Has Written 26 Reviews This user is on the site NOW (57 seconds ago)
* 14-Mar-2016(#4)
My memory is not clear, but I seem to recall some issue with a "blank page" related to the mobile site and it trying to redirect to that.

What layout are you in when you attempt to login (old, new, or mobile)? It may work better if you use m.gametz.com from the start.

There's a cookie that will set if you choose to switch to non-mobile or vice-versa (against what the default is). I think the past bug may have been related to some people blocking cookies too. Then it would cycle, trying to set a cookie but failing and coming up blank.

I assume you've checked to make sure you don't have cookies disabled.

3 days ago is an interesting clue. Did you make some change to your phone around that time? I don't think the site has changed in ways related to login. But, I'll check on that.
SirConnery
GameTZ Subscriber 1000 Trade Quintuple Gold Good Trader Secret Santa
14-Mar-2016(#5)
No changes to the phone. It's the only site I have the issue with.

Mobile all the time. I only use new desktop site on the iPad since the screen is bigger. I've tried the others too with a internet cache dump between each one as well as a phone restart. No change. I get blank page on everything. It's a page I can scroll so it's probably 2-3 pages long.

Right now I have Firefox installed for browsing this site and Safari for everything else. I'm just seeing if I can weed it out before next month when I go to Midwest Gaming Classic and will be accessing the site from the show.
bill
GameTZ Gold Subscriber GameTZ Full Moderator 600 Trade Quintuple Gold Good Trader Gold Global Trader (15) Has Written 26 Reviews This user is on the site NOW (57 seconds ago)
14-Mar-2016(#6)
I could be wrong, but it's probably something about your phone's Safari settings. iPhone are very common. So, if others were having the same problem, we'd be seeing more complaints.

Just to go over it, based on what my settings are on my iPad (I don't have an iPhone but they are pretty similar):

o Under Settings(app)->Safari -- "Privacy & Security" -- Block Cookies is set to "Allow from Websites I Visit"

o Settings(app)->Safari -- "Advanced" -> "Website Data" -> "gametz.com" try "edit" then negative -> Delete to remove it for gametz. That should remove cookies.

Based on what you wrote, maybe you did this already.

I use Chrome on my iPad most of the time, but I am able to sign on using Safari. Initially, I did have some trouble signing off. It let me, but then I was still signed on (stuck cookies). Using "Clear History and Website Data" from the settings app Safari page cleared that. Also, deleting it specifically from advanced also worked.

Closing Safari or rebooting your phone may help if it's somehow some stuck state thing.

If you get really desperate, I could try to give you a very insecure sign-on link (like the good ole days).
SirConnery
GameTZ Subscriber 1000 Trade Quintuple Gold Good Trader Secret Santa
14-Mar-2016(#7)
I did all that, still a blank page. I did a settings reset and same page. I'm backed up to the cloud so I'm going to wipe and restore since I have some free time.
SirConnery
GameTZ Subscriber 1000 Trade Quintuple Gold Good Trader Secret Santa
14-Mar-2016(#8)
I wiped and restored from backup. Still getting blank page. I may try wiping and setting up as a new iPhone later to see if there's a difference.
bill
GameTZ Gold Subscriber GameTZ Full Moderator 600 Trade Quintuple Gold Good Trader Gold Global Trader (15) Has Written 26 Reviews This user is on the site NOW (57 seconds ago)
14-Mar-2016(#9)
Ack! Let me try to look at it some more (tomorrow).

If I was standing over your shoulder, I could debug it. Maybe the log would show something (unlikely).

Prime
GameTZ Subscriber Quadruple Gold Good Trader Global Trader - willing to trade internationally
15-Mar-2016(#10)
Had a similar issue a few months ago. I can't find the Pm where bill walked me through, but it was an easy fix if I recall. Just took a bit to find where the issue was.
bill
GameTZ Gold Subscriber GameTZ Full Moderator 600 Trade Quintuple Gold Good Trader Gold Global Trader (15) Has Written 26 Reviews This user is on the site NOW (57 seconds ago)
15-Mar-2016(#11)
Thanks for the reminder. I found the pm we had. For you, it was your cookies settings causing the issue. Basically, part of what I wrote in post #6 here. ... Block Cookies should be set to "Allow from Websites I Visit"

Here's the image from the pm where I pointed it out to you:

image

But, SirConnery said he did all that. So, I'm stumped.

But, not having cookies on, can cause a blank page problem on the mobile site. So, either SirConnery is still affected by it despite the setting or there's something else that can cause a similar issue?

Hm, another thing to try might be to switch to the non-mobile site, then sign on. The blank page issue is just the mobile layout as far as I know. Actually, if cookies don't work, you may not be able to switch to non-mobile. So, trying that may be a clue.
bill
GameTZ Gold Subscriber GameTZ Full Moderator 600 Trade Quintuple Gold Good Trader Gold Global Trader (15) Has Written 26 Reviews This user is on the site NOW (57 seconds ago)
15-Mar-2016(#12)
Did you think about what might have changed on your phone 3-4 days ago when the problem started?
SirConnery
GameTZ Subscriber 1000 Trade Quintuple Gold Good Trader Secret Santa
15-Mar-2016(#13)
I had a carrier update from T-Mobile a week ago but everything is unchanged.
SirConnery
GameTZ Subscriber 1000 Trade Quintuple Gold Good Trader Secret Santa
15-Mar-2016(#14)
False alarm it's my phone.

I wiped and setup as a new phone and it works fine now.
bill
GameTZ Gold Subscriber GameTZ Full Moderator 600 Trade Quintuple Gold Good Trader Gold Global Trader (15) Has Written 26 Reviews This user is on the site NOW (57 seconds ago)
15-Mar-2016(#15)
yay \o/
DiamondDave
GameTZ Subscriber 350 Trade Quintuple Gold Good Trader Has Written 4 Reviews
15-Mar-2016(#16)
Wonder what would have caused it... Safari doesn't have plugin support, right?
AlphakirA
GameTZ Subscriber 450 Trade Quintuple Gold Good Trader Gold Global Trader (7) Has Written 1 Review
15-Mar-2016(#17)
You know you're addicted when you wipe your entire phone solely to have mobile access to GameTZ.
SirConnery
GameTZ Subscriber 1000 Trade Quintuple Gold Good Trader Secret Santa
16-Mar-2016(#18)
rykerrk wrote:
> Wonder what would have caused it... Safari doesn't have plugin support, right?

Not that I know of. We may never know.

Topic   Weird issue in Safari